'OnSessionStart' Action incompatible with the user provider eSpace

'OnSessionStart' Action incompatible with the user provider eSpace

  
Hi,

Today, during the normal work process, the messege "There was an error processing your request. Please try again later... "  was unexpectedly shown in the browser... This appened after clicking «Run and Debug in the personal area», has is normally done when developing. After this, we looked at the Error Log in Service Center, for more details about the error. This is what we get:

Id:
0866f50d-4983-4432-88fe-d9dcadac7768
Time of Log:
2012-12-18 18:47:23
eSpace:
AOECE
Tenant:
ServicosOnline
User:
 (2006)
Session Id:
0xndk455figbhzmi4pjlbo55
Server:
NTV41
Module:
Global
Message:
'OnSessionStart' Action is incompatible with the 'ServicosOnline' eSpace definition. Please update it.
Stack:
at ssAOECE.RsseSpaceServicosOnline.MssOnSessionStart(HeContext heContext)
at ssAOECE.Global.RunOnSessionStart()
at ssAOECE.Global.Application_AcquireRequestState(Object sender, EventArgs e)
at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
-Env-
eSpaceVer: 74 (Id=4503, PubId=5186, CompiledWith=7.0.0.14)
RequestUrl: http://online.dgo.pt/AOECE/hugolaibacas/Home.aspx?_ts=634914532428553960 (Method: GET)
AppDomain: /LM/W3SVC/1/ROOT/AOECE/hugolaibacas-24-130003299835424746
FilePath: D:\...\PS\test\AOECE\hugolaibacas\
Locale: en-US
DateFormat: yyyy-MM-dd
PID: 4652 ('w3wp', Started='18-12-2012 17:45:56', Priv=275Mb, Virt=5645Mb)
TID: 9
Thread Name:
.NET: 2.0.50727.4971

Why did this suddenly happened?
We have tried to solve it, but, some how, we can't... What can we do?

Thanks in advance.
Hugo Laibaças
I've seen this before too. The solution that has always worked for me is to make a solution that contains the entire application, and then tell it to Publish, and check the box "Publish with Full Compilations".

Hope this helps!

J.Ja

I am a newbie to Outsystems Platform. I encountered this error, while I was following the tutorial on "Your First Application" - List Records on Database. 

Can anyone advice me on how to get rid of this? I can't proceed to further tutorial lessons due to this error.
-------------------------------------------------------------------------------------------------------------------------------------------
'OnSessionStart' Action is incompatible with the 'Users' eSpace definition. Please update it.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.Exception: 'OnSessionStart' Action is incompatible with the 'Users' eSpace definition. Please update it.

Source Error: 


An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: 

[Exception: 'OnSessionStart' Action is incompatible with the 'Users' eSpace definition. Please update it.]
   ssSurv.RsseSpaceUsers.MssOnSessionStart(HeContext heContext) +66
   ssSurv.Global.RunOnSessionStart() +130
   ssSurv.Global.Application_AcquireRequestState(Object sender, EventArgs e) +1854
   System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +80
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +171
 

Hi
I've seen this before too. i published only the 'Users' eSpace.
I hope to have helped in colaboration post.
Best Regards
I'm getting this same message when the Users espace hasn't been published.  I only find out when I can't access other applications.  I publish the Users espace and it works for a while, but then it comes back again.  This is happening in our development environment, but I'm concerned that it could happen in production.  Is there anyway to prevent it from happening?
I'm getting the same area.  I've republished by User space from within Service Center.  Is there anything else I can try to get this back working again?

'OnSessionStart' Action is incompatible with the 'Users' eSpace definition. Please update it.
I ended up creating a solution with the problem espace and then clicked the checkbox "Publish with full compilations" before clicking publish next to current running version.  I still don't know what the problem was.
Thanks Rebecca, just tried that but still getting the error.  Strange, it's only in our QA environment, Dev is absolutely fine.
Hi Steve,

Didn't you get any incompatible producer warnings in the solution publish report?

Regards,
João Rosado
No, not at all João - the solution publish went through the usual steps but still the same front end error message.
I vaguely remember I had it also.


My workaround, instead of stubbornly publishing everything, I deleted the action (ofcourse saving the logic in clipboard or dummy espace), publish the espace. create a new OnSessionStart, paste the logic back in and voila. it should work.

Ok, perhaps a stupid question, but where is the OnSessionStart action?  I looked in the Users eSpace but no luck (that also appears locked for editing).  Is it elsewhere?
Just for completeness, I solved this by doing a push from Dev to QA environments and this resolved the issue.  Wierd one though.