ISAPI Filter and SEO Rules

  

Hello,

I need some guidance regarding the installation of ISAPI Filter.

In my enviroment, I'm using Windows 2008 R2 and Outsystems platform server v7.0.0.5 and I'm having a strange behavior regarding the installation of ISAPI Filter's.

I've installed the ISAPI filter on my IIS following the installation instructions. The problem is that, after adding the ISAPI filter I can't see it in any application pool. I've checked all of my app pool's and their is no ISAPI filter application.

Nevertheless event log show's the initialization of the OSISAPIFilter and I'm able to create rules.

After creating a SEO Site rule i wasn't able to access my eSpaces outside my VLAN, despite not having any zones created. After several attempts and without knowing why the SEO Site rule seems to be working fine but I stil cannot see my ISAPI filter application in any of my application pool's.

Thank you in advance,

Regards,

João Almeida

Hi João,

As the name says it's only a "filter", so it's normal if it does not show as an application.

If the log shows the loading correctly then it should be ok.

As for your second part, I'm afraid I can't help you without more details of what errors you were getting and what changed.
Could you access the applications correctly before applying the rules? At our filter level there shouldn't make a difference where the request was coming from.

Regards,
João Rosado
Hi João Rosado,

As described in the installation instructions and in the several posts across the forum the filter must be set in Outsystems application pool. As far as i know the filter must be in the same application pool as the eSpace using that SEO rule. Isn't this correct?

Regarding the second part, the error was the http forbiden error.

I've created a SEO site rule in order to access my outsystems platform from outside my network (outs.ambisig.pt -> outssrv).
If I tried to access my applications (in the same vlan)  using any of those names with hosts file pointing directly to the server everything work fine.
If i access the applications using my internal server name from any other vlan it also worked fine, but if I used the outs.ambisig.pt, from any other vlan except the same one of the server then http forbiden occurs.

Thanks