RichWidget Feedback_Message Clears Data on Page

RichWidget Feedback_Message Clears Data on Page

  
I'm having a problem with the richwidget Feedback_Message.

In particular, a user is entering data on a screen (radio buttons, text boxes, etc).  When they go to save, if they are missing information, I'd like it to tell them with a Feedback_Message.  However, the Feedback_Message richwidget seems to reload/refresh the page, which wipes out all the user's data they entered.

Is there a way to disable the refresh option?  I'm looking at copying the richwidget, and modifying it to not refresh (if possible without breaking the whole thing), but I'm wondering if there's a simpler solution that I've overlooked.

Thank you.

EDIT:  Apologies - I double-posted and deleted the duplicate.
Hi Chris,

The normal behavior is not to clear any data.
From your description it looks like you are ending your Save flow with a redirect to the same page. Your flow should end with a End node to allow it to stay on the same page with all current information.

Regards,
João Rosado
Thank you for your reply, João

For the particular flows in the cases I'm using these Feedback messages, they are indeed going to 'End' nodes, not to a (Current Screen) type of node, which is why I thought the Feedback message clearing my page was weird.  I'll poke at this some more to see if I've done something else incorrectly.

Could it have something to do with the 'Method' under the On Click attributes of my button?  I have them set to 'Ajax' currently (since the current methodology I'm replacing on this screen is hidden labels that are unhidden in certain validation sequences, then Ajax-refreshed).  Should the buttons be Submit instead?

Hi Chris,

Ajax is fine, none of the methods should clear data.
Are you doing any extra refreshes when it gets the problem? Or does it work correctly when you remove the feedbacks?

Can try to look at it if you can reproduce it in a sample eSpace.

Regards,
João Rosado
Sorry for the late reply; got taken off this project temporarily to focus on another job.

Odd, though - I tried it again and it works now.  I don't know what I did wrong in the beginning, but I appear to have stumbled face-first on the solution.  Thank you so much for your assistance, João.  I'm sorry this won't help anyone else looking for this issue, but hopefully I'm the only one who screwed it up badly enough to warrant asking!