I tried send mail using RichMail, but a message error 3auth login is returned.
My Service Center is configured for Email Amazon(SES).
How I  send emails to using the services Amazos(SES)?
Hi Marcos,

If you are using Service Center > Administration > Email settings I suppose you don't need RichMail. Please make sure you are inserting the server name, port, username and password of your Amazon SES account in the Email settings. Also, take a look into this discussion, please: http://www.outsystems.com/forums/discussion/7944/error-in-email-sending/ ? It might be what you are looking for.

On some occasions you might want to perform a telnet troubleshoot of your email server connection.

Regarding Richmail, you need to ignore all Service Center configurations, because that component stands alone to what respects your server Email settings. For using Richmail with authentication take a look at its public actions, there is one precisely for that:

Let me know how it worked, please.


I tried to ignore all Service Center configurations but i don't to save with success.
Hi Marcos,

The Richmail extension and the email configuration in Service Center are completly separate things. So you don't need to actually "remove" the configurations.

The configurations from Service Center will be used when you create Email screens in service studio and send them using the SendEmail action.

Then you have the Richmail extension that is a separate component (older, that then evolved to the Email Screens). One of it's limitations is that it does not work on SSL/TLS connections, that is one of the requirements for most cloud base email services (only allow the login operation under SSL).

I would recommend you to try and use the Service Center configurations + Email Screens and see if it works correctly with them.
Do you have any requirement that is not fulfilled by the Email Screens?

João Rosado
Have you figured out a way to setup the service center email settings to send out email via the Amazon SES.

The only fields in Service center are:

SMTP Server:
SMTP Port:

Amazon SES whats a check box for me to use TLS

what can I do to get around this.

Well, I have to say that sending email from Amazon SES with the OutSystems Platform is truly not an easy task.

The platform doesn't seem to be able to login via ports 25 and 587. If I set up an stunnel to access port 465 (SSL only), the platform is able to log in, but the message is rejected by Amazon. As my personal account is on the free tier, I do not have Amazon support to ask them exactly why the message is being rejected, and I can't figure out why it is from the available documentation.

I will try to setup an smtp relay and see how that one goes.
Well, here are the results of my findings:

The OutSystems Platform won't be able to talk with Amazon SES through the 25 and 587 ports (the ones which start unencrypted). It will return the 3AUTH LOGIN error Marcos mentions in the first post. Since the AUTH LOGIN part is done after STARTTLS, without instrumenting the Platform it's not possible to check what really is going on there.

However, fear not, cause it's possible to use the 465 port! And here's how I did it:

Step 1) Download Stunnel
Step 2) Configure Stunnel to create a plaintext interface to port 465 (see attached file)
Step 3) Configure the Platform to use localhost on port 6666 to connect to mail server
Step 4) Add in your username and password

This allows the platform to talk with Amazon SES, and provided you could send the email via SES, you'll be able to send it using the Platform.

There are some quirks to using Amazon SES service, which I came across while testing this. London Theme has a pattern ( data: image ) which will make Amazon SES refuse to send the email ( error 554 Illegal Content ), so you need to be careful with what theme you are using when trying to send emails via SES.

An alternative to Stunnel would be to setup an SMTP relay either using IIS or using one of the email servers SES documentation helps you with (postfix, exim, or sendmail ). In this case you'd typically use localhost:25 to connect to the email server without any password (authentication is done by your smtp relayer).

Let me know if you have any problems setting this up.
Ricardo Silva your stunnel instructions worked perfecly.  I am now successfully using the amazon SES email services.

Anybody looking to use the amazon SES for your outgoing email.  use the above instructions for setting up the platform.

I cant thank you enough for your help.  Thats why I love outsytems.  You guys always find a way to be the best.

Thank you


This information is outdated.

The last tests I made with the platform, it was able to talk with port 25 and 587 of Amazon SES, negating the need for the stunnel workaround.

Ricardo Silva wrote:

This information is outdated.

The last tests I made with the platform, it was able to talk with port 25 and 587 of Amazon SES, negating the need for the stunnel workaround.

What version will this not be needed. 10_?_?_?

I don't think OutSystems changed anything. It's possible Amazon SES changed something in how their service operated.

In any case, I've been having success with sending emails in the latest 9.1 and 10.0 releases.


We recently configured our Outsystems environment to use SES and are using port 25.  Some mails are going out but others are failing with an error: 

Error sending email 3360: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond    at System.Net.Sockets.TcpClient.Connect(String hostname, Int32 port)
   at #0Yc.#ZYc.#CZc.#ZYc()

Would you have any ideas about why this may be happening?  Thank you!

Hi Santosh,

I have no knowledge of this kind of errors being frequent when using amazon ses. 

This looks like a network problem. Is your environment hosted in an Amazon EC2 instance?

In any case, the platform should retry sending the email. Is it not doing this and always failing for that email?

Thanks Ricardo.  I found that Amazon SES throttles connections on port 25 but not on ports 465 and 587.  We were sending mails to several recipients at one time which was causing the problem. The Outsystems platform was trying to resend but it would do so in groups and therefore keep failing.   After switching the port it works fine.  

Copied from Amazon SES documentation for reference:

You are sending to Amazon SES from an Amazon EC2 instance via port 25 and you cannot reach your Amazon SES sending limits or you are receiving time outs.

Amazon EC2 imposes default sending limits on email sent via port 25 and throttles outbound connections if you attempt to exceed those limits. To remove these limits, submit an Amazon EC2 Request to Remove Email Sending Limitations. You can also connect to Amazon SES using ports 465 or 587, neither of which is throttled.