Running Service Studio on non-Standard DPI configuration

Running Service Studio on non-Standard DPI configuration

Hello everyone,

I'm writing this post because a lot of you have stumbled in this problem.

The problem is related with the DPI settings in Windows. Since Windows Vista we can change the default DPI settings of your monitors. What is DPI you may ask? Here is a small explanation of it, courtesy of Wikipedia.

This issue became more prevalent with the advent of high resolution displays, like the "famous" retina displays made by Apple. Thus, nowadays is not uncommon for a tablet (or even a notebook) to have a high DPI setting. Examples of this are the Surface Pro tablets that Microsoft sells.

However, Service Studio doesn't work in a non-standard DPI. For example, in a non-standard DPI the tabs at the top of the Service Studio (Process, Interface, Logic, Data) don't work and everything appears to be un-aligned. Note that this is not related to Windows 8 or anything. However, by coincidence, high DPI displays came around the same time as Windows 8 so some people mistook the problem for a operating system problem.

To see if you have a standard DPI, follow those steps:
  1. Right click or press and hold on an empty area of your desktop, and click/tap on Screen Resolution
  2. You will now see this screen:

If the percentage is greater than 100%, than you have a non-standard DPI setting.

I have a 1st generation Surface Pro tablet which, by default, have 125% DPI setting so you can read text correctly. That is why the Surface can have full HD resolution in such a small display and you can still read everything.

To work around the Service Studio problem, either change the DPI setting in the previous screen to 100% (not recommended in small displays since this changes the DPI across all windows) or, better yet follow those steps:
  1. Go to the folder where the Service Studio is installed (c:\program files\Outsystems\Service Studio by default)
  2. Right click the ServiceStudio.exe and select Properties. The following window appears.
  3. Click the Compatibility pane, and check Disable display scaling on high DPI settings.
The Service Studio will work without problems, but everything in it will be a little small... 
By the way, in windows 8.1 you can have different DPI settings per display so if you have a secondary display this could help...

Rui Eugénio
Hi all

You might run into similar problems when trying to run Service Studio on a virtual machine within a Mac. This is very frequent especially due to the widespread use of Retina displays.

If you are using a Mac and VMWare Fusion you need to follow these steps. Still, if you feel the text is too small in your Retina display, you can fix this with the instructions here.