[Salesforce Connector] Log In Error Message : Unable to connect to the remote server

[Salesforce Connector] Log In Error Message : Unable to connect to the remote server

  
Forge Component
(7)
Published on 2015-08-19 by Goncalo Borrega
7 votes
Published on 2015-08-19 by Goncalo Borrega
I have tried the connector in different environment servers and it works, except for one. Kept getting
'Unable to connect to the remote server' error using SalesforceLogin. What might be the cause of the error?
Does it have something to do with the server configuration? Is SSL Certificate required? 
Hi Dus,

Are you able to retrieve more details on the error you're getting?
Have you inspected the issue on Service Center console > Error Logs and then on that specific error accessing the Details page?

If necessary, you can try auditing inside the SForce.xif extension to see what the problem is, to read the whole exception stack trace, for example.

Also, can your server access the Salesforce.com API endpoint? Looking into the SForce.xif extension, the web reference is using https://login.salesforce.com/services/Soap/u/25.0  Can you test if this endpoint is reachable from the server having this issue?

Let us know how these suggestion work for you please, so we can help you further.

Regards,
Pedro
Hi Pedro,

No there is no error log in service center because the error is from SalesforceLogin.Message..
I have the same problem as
http://salesforce.stackexchange.com/questions/13532/api-login-call-is-failing-when-logging-in-on-different-pcs
Where or how can I add a proxy? 

Thank you.

Hi Dus,

I've just replied to one of your team members (Jollie) through the Customer Success Program channel on that precise topic. I believe you can configure the proxy settings through the SForceService .NET class inside the SForce.xif extension. Can you please check the image in attach?

This finding also seems aligned with a similar subject post in Salesforce.com Developer Discussion Forums.

Can you please try out and let me know the results?

Cheers,
Pedro
Hi Pedro, 

I added these and it works now:

WebProxy myWebProxy = new WebProxy();
// Real address used in actual code
Uri newUri = new Uri([proxyserver:port]);
myWebProxy.Address = newUri;
myWebProxy.Credentials = new NetworkCredential([username],[password],[domain]);
binding.Proxy = myWebProxy;

Thank you very much.