[Field Services Mobile] great app!! how do I change it to personalise for a demo

[Field Services Mobile] great app!! how do I change it to personalise for a demo

  
Forge Component
(16)
Published on 8 Jan by Sofia Mourato
16 votes
Published on 8 Jan by Sofia Mourato

Hi guys, 

Great work on this app.  I'd like to use this for a pitch/demo and I was wondering if you could point me to some information on how to change the demo user and the assets and locations?  I've been looking through the spreadsheets and can see some content for Australia, but It seems to default to USA.

Steve,

To be able to create a localised demo, you would need to edit the FS.SampleData.xlsx file (in the resources of the FieldServicesMobileSampleData module) as this is what is used to populate the data.

Try http://www.generatedata.com/ to generate localised data for users and sites.

Ouen


Hi Ouen, 

Thanks for the quick reply and that generator is an amazing resource!  I already have the localised content by downloading the FS.SampleData.xlsx file and the Regions file and changing them.  Unfortunately I can't see the new data when I refresh the app and when I try modifying the default USA data, it seems to break some relationships with other data so no tasks show for Patricia.  I tried modifying the sample data but it's not showing up.  I was hoping there might be some documents about how the sample data relationships are set up:

  • How are tasks and region related to sample user 'patricia'  
  • where is the default sample region set.  seems to be just selecting the 4th entry of the regions table.

Ok this is driving me nuts.  I've gone into Employee Services and Field Services and updated the bootstraps for all the sample data and changed them to trigger on publish.   For the life of me, I can't get them to work.  

Hi Steve,

I'd like to help you get that working but I don't understand exactly where you are at the moment. Please confirm:

  • You customised the data in the sample data worksheet
    • From what I read you modified the data for the US - was it Georgia or California?
  • You uploaded the new worksheet to the module and published it
  • You ran the bootstrap timer
    • You mention you changed the timer to run on publish - wasn't it already set to do that?

After doing this, you still don't see your custom data.

  • Are you trying the app on your browser or running the native app on your mobile device?
  • If you check the database, do you see your customised data in the entities?
    • If not, the bootstrap process didn't succeed
    • Make sure you have the correct region selected (check the SelectedRegion site property in FieldServicesMobileSampleData)
    • Make sure you published the module with the updated excel file and check Service Center for errors during the bootstrap timer
  • If you do see your customised data in the DB entities, this would suggest a local storage sync issue
    • If you're in this scenario, the troubleshooting depends on how you're accessing the app
      • If you're using chrome, open a new tab in Incognito mode and access the app - this will ensure your local storage tables are empty
      • If you're using the native app, long press on the application header with two fingers until the data options screen shows up - tap Reload Local Data
        • If you can't get the screen to popup, on Android use the system's settings menu to clear the app's data. On iOS there's no option but to uninstall the native and install again
    • Once you do one of these procedures to ensure you refresh the local storage, do you see your customised data?

Hi Daniel,

THanks for this detailed checklist!  I'll go through this morning and make sure I've done/tested/followed them.  The region changes. sometimes its Portugal, sometimes its California.  I'm trying to include content for Australia.  First I tried adding new content to the spreadsheets, but that didn't work so I tried overwriting some of the US content.  Yes on some of the bootstraps I've had to change them to publish (were set to daily xxxam/pm).  I've tried running it on browser and mobile.  no change (apart from region).  No new data coming in, so bootstraps not working.  I was checking the timer log on Service Centre, no errors.  I didn't manually set SelectedRegion yet.  will try that.

I will try your suggestions  



Hi,

it is great application. I have changed data and it is working.

Do you have any document releated to this application actually i want to know the follow of the application functionality ?

Thank you,

Mani

Hi Mani,

We don't have any specific documentation for the application functionality but I would say that it is almost self-explanatory.

Is there any specific explanation you are looking for? Any doubts on a specific scenario?


Let me know if I can help you further!

Hi,

Am using this Application, in that Map was not showing it showing as

 "OOPs Something went wrong...

This page don't load google map correctly . See the java Script Console for technical details. "

please help me to solve this..

Monee wrote:

Hi,

Am using this Application, in that Map was not showing it showing as

 "OOPs Something went wrong...

This page don't load google map correctly . See the java Script Console for technical details. "

please help me to solve this..

Like the message says, you should open the JavaScript Console (Ctrl+Shift+J works on both Chrome and Firefox, on IE/Edge press F12 then select the Console tab).

That will hopefully give you extra information on what's going on...


Hi Monee,

This was related with an old API Key that we were using on the map and is not really needed.
We have uploaded a new version that fix this problem so please update it and let us know if you need further help.

Kind Regards,
Sofia

Ana Sofia Mourato wrote:

Hi Mani,

We don't have any specific documentation for the application functionality but I would say that it is almost self-explanatory.

Is there any specific explanation you are looking for? Any doubts on a specific scenario?


Let me know if I can help you further!


Hi Ana Sofia Mourato,

I am customizing this application. Actually I want to know about functionality for "Write a Note" label in WorkOrderDetails screen but no link added.

In dashboard screen, I have seen Messages / WorkOrder buttongroup. Any input screen is available for Message / Work Order notes ?



Thank you,

Mani

Hi Mani,

We don't have those features implemented. The data shown there is sample data created from the bootstrap.
If you want to have it you'll need to implement a logic for that or change the data in the excel file on FieldServicesMobileSampleData eSpace.

Let me know if you need further information.

Kind regards,
Sofia Mourato

Hi Sofia Mourato,


ok.Thank you.


Regards,

Mani