[Facebook Login Plugin] "Invalid key hash" error when trying to login using facebook

Forge Component
Published on 2018-11-09 by André Gonçalves
2 votes
Published on 2018-11-09 by André Gonçalves

Hi Grazina,

Now I am getting the error "Invalid key hash". I again verified the key hash set in the facebook developer app page, by re-generating he key hash and it is same as the one that is already there in the facebook app settings.

Also. with the same hash key it was working fine earlier and I don't know why this issue started to appear.   

Same problem..

Any suggestion?

Hi Grazina,

Any help on why this is happening ?

I even downgraded to the first version of this plug-in, still the same error is occurring.

I have this problem too. Anyone found a solution?

Best regards

Hi all,

Please follow instructions from Google Login Plugin from this page, point 3 through to 4. 


The generated application on Android must use the certificate for which the fingerprint MUST MATCH the one configured on facebook developer console.

You cannot use your application on the browser nor on OutSystems Now, since you need specific package name to match the one in the facebook settings page. You need to generate the application using the Native Platforms tab on your application in Service Studio.

Please follow these instructions and let me know if it solved your issue. Here's a short checklist though:

  • Have you generated a specific certificate for your Android application?
    • You have used this certificate on the Native Platform's tab under "> Configure Keystore"
    • You have configured the fingerprint for this particular certificate on Facebook's developer console.
  • Have you defined your App identifier and set it up on both Native Platforms tab and Facebook's developer console?
  • Have you generated the application using Native Platform's tab and are you using that application to test your integration with Facebook login?

Kind Regards,

João Grazina