Producer 'OutSystemsUIMobile' module definition is incompatible. Please update it.

How to resolve this , as i am getting this alert while running the mobile application.

Hi Nitesh,

A couple of people had the same problem with other modules. you can check the solutions they tried here.

Regards,

Marcelo

Solution

I tried to resolve it with few suggestions which is given there. But for me i did it through this : 

when i checked Template phone,Template tab, Template universal references in Manage DependencyWindow, click ok.


Thanks Buddy Marcelo

Solution

Nitesh Pandey wrote:

I tried to resolve it with few suggestions which is given there. But for me i did it through this : 

when i checked Template phone,Template tab, Template universal references in Manage DependencyWindow, click ok.


Thanks Buddy Marcelo

Hi Nitesh,

I am also facing the same error. I saw your solution but I am not able to see Template phone, Template tab or Template universal references in Manage Dependency window.

Please help me with this.

Regards,

Rashmi Hatwar


Same problem....this is completely new and different for me, please help...

Hi, I'm also facing similar issue "Producer 'OutSystemsUI' module definition is incompatible. Please update it." 

This started after I added Silk UI Mobile Preview dependency. I also updated my OutSystems UI to 2.4.1.


thanks,

Shreyash 

Hi @Shreyash Maheshwari, i was in the same scenario and the steps below solved my problem, you can try:

1- Open the service center and go to SilkUIMobileCustomizerPreview Module Detail. Probably you will see that the reference to OutSystemsUI is not ok.


2 - Open the SilkUIMobileCustomizerPreview module and go to Manage Dependencies. Click on "Refresh All" and after on "Apply". With the dependencies updtate publish the module.


3- The last step is update the module that  references SilkUIMobileCustomizerPreview


I hope this help you!!!