[Amazon S3 Connector] Size limit on upload

Forge Component
(5)
Published on 12 Jul by Guilherme Pereira
5 votes
Published on 12 Jul by Guilherme Pereira

Can you please confirm what is the size limit for a single file to be uploaded. I tried uploading documents of 85MB and that worked but then next closes document I have is 141MB and that seems to be erroring out over and again.

Can you please confirm the size limits, or if what you have tested.

Thanks.

Hi Yasser,


The connector does not impose any limit and as far as I know neither does the SDK.


So I believe one of two things could be happening:


1) You could be hitting the max request upload size configured on your server. You need to check with your sys admin (or OutSystems support if your using OutSystems Cloud) to check the limit. 

2) You could be getting some kind of timeout.


What do the logs on Service Center show?


If you discover one of those as the problem, you could try and use FactoryConfiguration to change the web.config of your app to allow a larger limit  and/or larger tomeout similarly to what's described here


Let us know if you were able to solve the issue.


Cheers,

Guilherme