[Geofence Plugin] Error generating ios mobile app

Forge Component
(0)
Published on 2019-08-28 by Experts
0 votes
Published on 2019-08-28 by Experts


Hi,

While generating the mobile app for ios, i am getting the below error:

Error generating application. At least one Cordova plugin used in the build requires Swift but no "Swift Language Version" build setting was defined. Check your plugins configuration.

Can you please help me to resolve the below issue. i am using the demo app.

Regards,


I have the same problem. I found this, but it didn`t work:

https://www.outsystems.com/forums/discussion/34435/update-plugin-swift-version/

Mohammad Hasib wrote:


Hi,

While generating the mobile app for ios, i am getting the below error:

Error generating application. At least one Cordova plugin used in the build requires Swift but no "Swift Language Version" build setting was defined. Check your plugins configuration.

Can you please help me to resolve the below issue. i am using the demo app.

Regards,


You can put in you app solution this configuration

{
    "plugin": {
        "url": "https://github.com/akofman/cordova-plugin-add-swift-support.git#2.0.2"
    }
}

And in the plugin confirm if this setting are there

{
    "plugin": {
        "url": "https://github.com/OutSystemsExperts/cordova-plugin-geofence#hotfix/swift3",
        "variables": [{
            "name": "USELEGACYSWIFTLANGUAGEVERSION",
            "value": "1"
        }]
    }
}