Users Provider Module integrated with AAD

I've successfully configured my personal environment with an Azure AD tenant. I know it's working because unless I specifically use the full Users Module login URL, I get redirected to AAD and get denied access due to permissions - as expected.

After seeing this in action, I created a very simple one page Reactive app, ensured the User Provider Module was set to Users and the page required Registered permissions.

However, when I run the app, I get the standard Users login screen and am not redirected as you'd expect.

According to the Authentication training course, this is all you need to do for any of the built in authentication methods and providers.

Anybody else experienced this and solved it?

Cheers,

Roy

Solution

The SAML 2.0 support provided by the Users module is currently only applicable to Traditional Web applications as stated on Configure SAML 2.0 Authentication

In order you use it on a Reactive Web Application you'll need to used the IdPReact component from the OutSystems Forge. The component also includes a demo on how to configure it and the process should be similar to How to configure OutSystems to use identity providers using SAML


Cheers

Solution

Nuno Veiga wrote:

The SAML 2.0 support provided by the Users module is currently only applicable to Traditional Web applications as stated on Configure SAML 2.0 Authentication

In order you use it on a Reactive Web Application you'll need to used the IdPReact component from the OutSystems Forge. The component also includes a demo on how to configure it and the process should be similar to How to configure OutSystems to use identity providers using SAML


Cheers

Thanks Nuno,

I presume I can build a common module that I can build this in to rather than having to do it for every app?

Cheers,

Roy