[Mobile Force Install Manager] Mobile force install manager Plugin stopped working after getting latest version

Forge Component
(3)
Published on 2019-11-04 by José Fábio Vieira
3 votes
Published on 2019-11-04 by José Fábio Vieira

Hello,

I updated the plugin with latest version 2.0.2 (O11). After update, the component is not comparing the version numbers correctly and hence it do not display update screen which will ask user to force update.

Analysis - I can see in the aggregate- App_VersionNumber has filtered conditions to return the data if server version is not matching with the device version.

I see the the condition - "SystemFlagMustInstallNewBuil = true" is failing as i see table has "false" values for all the records.

We never used to manually change it after pushing the build to playstore. Now documentation says that we should set the flag "ON" for the version number for which we need user to force update the app.

Please suggest what is changed in the latest version which made it to stop working ?

Anyone faced such issue after recent update ? We are facing this issue in production and it's very critical.

Any pointers will be helpful !

Thanks,

Vani


Hi Vani,

Do you have logs to confirm that all values are correct?

Cheers,

António Pereira