Internal Error Message during publish

Hi Everyone,

I am Having this kind of error when I am trying to publish


Internal Error
An error occurred in task 'Update meta database model':
Object reference not set to an instance of an object.
Details : System.NullReferenceException: Object reference not set to an instance of an object.
   at OutSystems.HubEdition.DeploymentController.Database.DBScriptsExecutor.UpdateDb(String eSpaceName, HEMessageArrayList warnings, ObjectKey eSpaceKey, ObjectKey applicationKey, Int32 eSpaceVersionId, DeployPhase phase, String uniqueId, IDatabaseAccessService databaseAccessService, IIsolatedDbConfigurationService isolatedDbConfigurationService, IApplicationDbConfigurationService applicationDbConfiguration)
   at cs#erqolxha.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
Exception Details:
[1] Internal Error: An error occurred in task 'Update meta database model':
Object reference not set to an instance of an object.
Details : System.NullReferenceException: Object reference not set to an instance of an object.
   at OutSystems.HubEdition.DeploymentController.Database.DBScriptsExecutor.UpdateDb(String eSpaceName, HEMessageArrayList warnings, ObjectKey eSpaceKey, ObjectKey applicationKey, Int32 eSpaceVersionId, DeployPhase phase, String uniqueId, IDatabaseAccessService databaseAccessService, IIsolatedDbConfigurationService isolatedDbConfigurationService, IApplicationDbConfigurationService applicationDbConfiguration)
   at cs#erqolxha.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at cs#erqolxfs.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at OutSystems.HubEdition.ServerCommon.Tasks.SequentialTaskRunner.Run()
   at OutSystems.HubEdition.DeploymentController.Tasks.OneClickPublish.OneClickPublishTask.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at OutSystems.HubEdition.DeploymentController.Compiler.cs#bhihcgjm.cs#rweuvvwj()
   at OutSystems.HubEdition.DeploymentController.Compiler.cs#pwerbjhy(Object fi)
   at OutSystems.HubEdition.ServerCommon.SandboxAwareThreadPool.sc#hjrysmqz.sc#vqskwbxc(Object gd)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
[2] System.NullReferenceException: Object reference not set to an instance of an object.
   at OutSystems.HubEdition.DeploymentController.Database.DBScriptsExecutor.UpdateDb(String eSpaceName, HEMessageArrayList warnings, ObjectKey eSpaceKey, ObjectKey applicationKey, Int32 eSpaceVersionId, DeployPhase phase, String uniqueId, IDatabaseAccessService databaseAccessService, IIsolatedDbConfigurationService isolatedDbConfigurationService, IApplicationDbConfigurationService applicationDbConfiguration)
   at cs#erqolxha.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()




What should I do in this kind of error?

Hello Gerald,

It seems that you're having some problems deploying a new version of the database model.

Are you performing any changes over the attributes in your entities? Are you working with static entities?

If you try to publish the deployed version, does it give you the same error?

Rui Barradas wrote:

Hello Gerald,

It seems that you're having some problems deploying a new version of the database model.

Are you performing any changes over the attributes in your entities? Are you working with static entities?

If you try to publish the deployed version, does it give you the same error?

No I just open my Personal Environment and I tried to publish my module, I also tried to create a new module and publish it but I still get the same issue

Do you have any entities defined in your module? Can you show me the entity diagram between them?

Did you try publish through service center? If you tried and continue without publish, I will ask you to send a feedback through Service Studio, and open a Support case, please. 

Cheers

Gerald Emmanuel Malaca wrote:

Hi Everyone,

I am Having this kind of error when I am trying to publish


Internal Error
An error occurred in task 'Update meta database model':
Object reference not set to an instance of an object.
Details : System.NullReferenceException: Object reference not set to an instance of an object.
   at OutSystems.HubEdition.DeploymentController.Database.DBScriptsExecutor.UpdateDb(String eSpaceName, HEMessageArrayList warnings, ObjectKey eSpaceKey, ObjectKey applicationKey, Int32 eSpaceVersionId, DeployPhase phase, String uniqueId, IDatabaseAccessService databaseAccessService, IIsolatedDbConfigurationService isolatedDbConfigurationService, IApplicationDbConfigurationService applicationDbConfiguration)
   at cs#erqolxha.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
Exception Details:
[1] Internal Error: An error occurred in task 'Update meta database model':
Object reference not set to an instance of an object.
Details : System.NullReferenceException: Object reference not set to an instance of an object.
   at OutSystems.HubEdition.DeploymentController.Database.DBScriptsExecutor.UpdateDb(String eSpaceName, HEMessageArrayList warnings, ObjectKey eSpaceKey, ObjectKey applicationKey, Int32 eSpaceVersionId, DeployPhase phase, String uniqueId, IDatabaseAccessService databaseAccessService, IIsolatedDbConfigurationService isolatedDbConfigurationService, IApplicationDbConfigurationService applicationDbConfiguration)
   at cs#erqolxha.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at cs#erqolxfs.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at OutSystems.HubEdition.ServerCommon.Tasks.SequentialTaskRunner.Run()
   at OutSystems.HubEdition.DeploymentController.Tasks.OneClickPublish.OneClickPublishTask.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()
   at OutSystems.HubEdition.DeploymentController.Compiler.cs#bhihcgjm.cs#rweuvvwj()
   at OutSystems.HubEdition.DeploymentController.Compiler.cs#pwerbjhy(Object fi)
   at OutSystems.HubEdition.ServerCommon.SandboxAwareThreadPool.sc#hjrysmqz.sc#vqskwbxc(Object gd)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
[2] System.NullReferenceException: Object reference not set to an instance of an object.
   at OutSystems.HubEdition.DeploymentController.Database.DBScriptsExecutor.UpdateDb(String eSpaceName, HEMessageArrayList warnings, ObjectKey eSpaceKey, ObjectKey applicationKey, Int32 eSpaceVersionId, DeployPhase phase, String uniqueId, IDatabaseAccessService databaseAccessService, IIsolatedDbConfigurationService isolatedDbConfigurationService, IApplicationDbConfigurationService applicationDbConfiguration)
   at cs#erqolxha.InnerExecute()
   at OutSystems.HubEdition.ServerCommon.Tasks.AbstractTask.Execute()




What should I do in this kind of error?



Hello, is there a solution to this problem? It happened to me too.


Thanks.

This is the problem that was reported in this thread. That thread already has a workaround.

it also happen to me,, when i insert my own data from excel,, does anyone can help ?

If you have any previous published version then try to publish.

OR

try to restart outsystems services once and then try to publish.it should resolve.

Hi Gerald Emmanuel Malaca,

I have few questions here ,

1. Is it happening with all the modules or with any specific module?

2. Did you recently updated the environment and it start happening after that?

3.If this is happening just with a specific module and if you have other published version of that module , try to republish any of the old version.

If not at all  it works create a support case on Support@Outsystems.com and let them know the steps and issue details.


Regards,

-PJ-