[Discovery] Still doesn't work with Oracle

Forge Component
(104)
Published on 23 Aug by Davide Duarte
104 votes
Published on 23 Aug by Davide Duarte

Hi.

New to Outsystems.

We still have double entries e.g. of Apps.

Snapshot still doesn't work at all. (see error below).

Is this maybe a data issue? Is there a way to clear all data and begin with empty tables?

What do you recommend?

Regards Alex


-----------------------


Runtime Error in module 'DiscoveryProbe':

Error executing query. Error in advanced query UpdateModuleDefinitionsForEspacesOracle in Modules_Reload in DiscoveryProbe (UPDATE {ModuleDef} MD   SET (MD.Description, MD.Name, MD.ApplicationDefId, MD.IsDeleted, MD.Kind, MD.SS_Key, MD.EspaceId) =       (       Select EV.Description, E.Name, AD.Id, 0, 'oml', E.SS_Key, E.Id       From {Espace_Version} EV       Inner JOIN {Espace} E ON E.[VERSION_ID] = EV.[ID]       Inner JOIN {Module} M ON M.[ESPACE_ID] = E.[ID]       Inner JOIN {App_Definition_Module} ADM ON ADM.[MODULE_ID] = M.[ID]       Inner JOIN {ApplicationDef} AD ON ADM.[APPLICATION_ID] = AD.[APPLICATIONID]       Where MD.[ESPACEID] = E.[ID] and E.[IS_ACTIVE] = 1 AND AD.[ISDELETED] <> 1       )  Where MD.Kind = 'oml'       ): ORA-01427: Unterabfrage für eine Zeile liefert mehr als eine Zeile

Hi Alex,


I had the same issue in the past.

I removed the component and installed again with the latest version.


You can use DB Cleaner to remove the deleted modules and entities.


I hope this helps

Luís

Solution

Hi Alex, 

Have you tried to install the new version 5.0.8?

If so, could you try to run the timer BootstrapFirstSnapshot  from module DiscoveryProbe and let me know if you still have errors on Service Center log?


Thanks

Solution

Hi Sérgio.

Thanks for your reply. It worked! We have no duplicate entries anymore.

Then snapshots completes now without any error.

The only issue I saw at first glance: Number of screens,blocks, actions, ... are set on some modules to 0 (zero) despite having more.

Regards Alex