[Secure Device Plugin] Plugin detected as jailbroken device for the genuine user device
Question
Forge component by André Vieira

Hi Andre,

I am Salim. Actually we are using this Secure Device Plugin from our mobile banking application to detect the jail broken devices. It is working fine until we received a case from our customers as they are getting an error that "The application does not run on a device that is jailbroken". However this message is appearing to our customers who are having genuine iOS devices. We started developing the mobile banking application from OutSystems 10 and recently upgraded to version 11 and we are using version 2.0 of this plugin.

So far, only iOS users are getting this error. We need your support to resolve this issue.   You can find the attachments contains the screenshot of the customer device information. 


Thank you,

Salim.


ImagefromiOS1.jpg

Any update from this? I got the same issue.

Hi Salim and Joseph.

The capabilities provided by this plugin are now provided by the platform through AppShield.

This is a component that is very hard to maintain and doesn't really make sense to keep it alive when this functionality is now provided by the platform. I have deprecated the component.

You can find more information about AppShield here.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.