Service Studio Debugger ignores my breakpoints

Service Studio Debugger ignores my breakpoints

  

Hello,

Until yesterday morning, Service Studio debugger whas working fine.

Now I cant debug any eSpace on the development server, it simply ignore all the breakpoints I put in them.
On my local server, it works normally.

I publish the eSpace, press F6 to run the application, get the messages that my personal area is updated and that
the eSpace is ready to be debugged. Click the open in browser button, test the application and it does not stop
at any breakpoint.

My colleagues, on the same server, have no issues with the debugger.

Any ideas of what went wrong?
Thank you for your help.

Best regards,
Rui Pinto

Service Studio 5.0.2.22
Windows 7 Enterprise x64

Hi Rui,

You can experience debugger problems in case you have a poor connection to the server.
Is there a way you can either change or restart your connection and check if the problems persist?

Regards,

Daniel Lourenço
OutSystems

Hello Daniel,

Thank you for your response.

I can't change the connectition because I'm working on the client.
I've restarted my machine several times, reinstalled Service Center, used a different username on Service Center and the problem still happens.
What else can I do?

Best regards,
Rui Pinto
I just have to ask: have you tried debugging a simple screen, with just a button and an action?

Hello,

Yes, I created a simple eSpace with a button and publish it on the development server: the debugger do not works.
If I publish it on my local server, the debugger works.

Best regards,
Rui Pinto
Hello Rui

Have you tried Service Studio 5.0.2.26? Does it change anything?
OutSystems R&D has fixed a problem with Service Studio that lead to incomplete creation of the debug area, which resulted in not stopping in breakpoints and other similar problems.

I suggest you give it a try! Please let us know how it goes.

Cheers,

Hello,

I will try it and post my findings.

A quick question: is it possible to use different versions of Service Studio within the same team?
Must every team member use the same version?

Thank you for your help.

Best regards,
Rui Pinto
Hello Rui

Before answering your question, I would like to clarify the difference between version and revision in OutSystems. For example, when referring to Service Studio 5.0.2.26
  • The first two sets of digits are the version number. In this case, 5.0;
  • The third set is the release number. In this case, 2;
  • The forth set is the revision number. In this case, 26.
With OutSystems, you must have the same version & release numbers in Platform Server, Integration Studio and Service Studio. So, if your Platform Server is 5.0.2.x, you cannot use Service Studio 5.1.0.x. But you can use different revisions of Service Studio, i.e. if only the last digit changes - in that case, all will be compatible. That means that you can use Service Studio 5.0.2.26, another member can use 5.0.2.16, and so on.

Note however that, sometimes, OutSystems may need to break compatibility with previous revisions. Before installing a new revision, make sure to check the compatibility details. For example, Service Studio 5.0.2.26 states:
  • Compatible with Platform Server release 5.0, versions 5.0.2.3 or later
  • Compatible with Service Studio release 5.0, versions 5.0.2.3 or later
  • Compatible with Integration Studio release 5.0, versions 5.0.2.3 or later
Hope that this information is useful.
Cheers,
Starting on OutSystems Platform 9.0.1.15 and 8.0.1.43, there's a new setting that might help if your debugger is not working properly.
Check out this post.