[Html2PdfConverter] How to install the latest version in Windows without MinGW
Forge component by Miguel 'Kelter' Antunes
Application Type
Traditional Web

I noticed there are a few questions in the support on how to install this in Windows now that there is no MinGW version (Bleeding Edge) to download on the latest versions. Here is how to set it up without it using the latest versions available on the official download page.

1. Download the latest Zip/7z from the website - currently its this one:

2. Extract the files to your computer. Inside you will find a bin folder and inside the bin folder the files you need.

3. Go to the administration screen on the app.
Upload each file to its own section:
wkhtmltopdf.exe = PDF Generator
wkhtmltoimage.exe = Image Generator
wkhtmltox.dll = Additional Binaries (note this is only 1 file not 3 as the image below)

After that you should be good to go, and you can go ahead and test generating a PDF.

Andre

Champion

I have the same situation here:

1º) I have following the instructions (only with one file in libary section) and i have this feedback error:

2º) If i change the file in libary section to dll with bin folder, i recevied this error message:


Can help?


Are you upgrading or is this a clean install? I only found one DLL (wkhtmltox.dll) to upload as you can see from the screenshot, so I just uploaded that file to the additional binaries section (I uploaded the individual files rather than the folder, or the zip). Are you not able to do the same? If this is a fresh install, there should be no files visible in the additional binaries. Can you share a screenshot of the admin screen?

Champion

Hi,

It's a clean install. When i try to upload the dll file i get the last erro image.


But my admin screen is this:

I already upload the both generator and has no problem. My only problem is when i upload the DLL file.


Cheers

Thiago, I am not sure what might be causing this.

The only thing I can think of, is this personal or enterprise environment?
If this is an enterprise you should leave this option empty if it is a personal you need to select it:

Otherwise Im not sure why this is causing an issue uploading.

Champion

Is enterprise, and i have this:


I have notice the percentual of uploading and when the % hit 38 they stop and show a error message

Can you click execute with low priority checkbox and try again?

Champion

I finally upload the file but when i use the GeneratorPDF i get this error:

But i put the correct URL

Hi Thiago,

Have you tried to generate with a public lightweight page such as www.google.com? What's the result?

Have you tried to generate a pdf with another page from your app?

Cheers,

Guilherme

Champion

Hi Guilherme,


Yes i have in both cases (using anonymous role) and the error is the same. 

I have another collegue that has the same problem and it occured westerday.

Hi Thiago,

If you're not able to print even a google page it's a problem with the component configuration. You can try and follow the installation steps and check the FAQ and try different version of wkhtmltopdf. 

In the end if it fails you may want to try other PDF printing components on forge such as UltimatePDF

Cheers,

Guiherme

Champion

Hi,


This component is not working, i use the UltimatePDF.


Cheers

HI Thiago,


Glad you found a working solution. In any case I've just tested Andrés instructions with the latest version and it works as expected. In you screenshot it seems you were not uploading wkhtmltox.dll in the binaries list this is how it should look like.


André, I'll link your instructions in the Main FAQ.

Cheers,

Guilherme

Champion

Hi, 

The first print i didn't upload, but after i have uploaded and not working too.


So i found other soluction. But thanks anyway.


Hello, you can show the soluction here ?

Regards,

Joab

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.