[CKEditor.Reactive] How to enable Spell Checker in CK Editor by default?
Forge component by Fábio Fantato Rodrigues
Application Type
Reactive

Hi All,


How can I enable spellchecker by default in ckeditor?

Also I am using exact  same configurations of ckeditor demo application but for some reason in my toolbar first line tools are not clickable. Looking forward to your reply. 

Thanks

Hi,

May be your native browser settings are disabled by default just enable it will set creditor spell check work

please check the below link for more details 

https://ckeditor.com/docs/ckeditor4/latest/features/spellcheck.html

Hope this helps 

Regards

AD

Hi AD,

My browser spellcheck setting is enabled. Not sure how to update config.disableNativeSpellChecker = true;  configuration in  OutSystems.

Thank you for your time.

Hi Nannu,

You can set your config file by passing your configurations in the 'Config' input parameter. You have an example in the image below, where the spell checker is deactivated.

Hi @Nannu,

Recently I had the same problem in one of my projects in production, I realized that we had installed an OutSystemsUI update, and that could be the source of the problem.

We solve it this way (please add this to your theme)

.cke_toolbar {

       z-index: 999;

}

Hope this helps.

Regards,

JR

Hi Joao,

I tried this but it didn't work. After Inspecting my page I found this.

<body contenteditable="true" class="cke_editable cke_editable_themed cke_contents_ltr cke_show_borders" spellcheck="false"><p></p></body>

Not sure how can I change spellcheck value globally on my page. Thank you

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.