Compilation Error Using Integration Studio

Compilation Error Using Integration Studio

Hi, I am using the Integration Studio from outsystems, and trying to access my sql database from the service studio.  So I used the Integration studio and imported the tables into a new extension.

I Imported a single table from a sql server database, and then clicked the publish button.  

However, it returned a compilation error saying:

.NET Compilation.
C:\Users\aalt\Desktop\Adam's Projects\ContactsExtension\Source\NET\ContactsExtension.sln.cache(59,5): error MSB4126: The specified solution configuration "Release|BWS" is invalid. Please specify a valid solution configuration using the Configuration and Platform properties (e.g. MSBuild.exe Solution.sln /p:Configuration=Debug /p:Platform="Any CPU") or leave those properties blank to use the default solution configuration.

What should I do?
Hi Adam, and welcome to the OutSystems community forums.

This seems like a problem with Visual Studio and its confirguration. What version of Visual Studio are you using?

One way to try and get Visual Studio to self-correct its settings is to open it in Integration Studio. You can do it by clicking the second right-most button, which will say "Edit Source Code .NET" and then try to compile it in Visual Studio by clicking the Build > Build Solution menu item. If that doesn't do it, notice the drop-down box to the right of a green "play" shaped icon (which is the Start Debugging icon). That drop-down box specifies the configuration. Change it to Debug - or Release - and see if it works best.

After you get it to compile in VS, save it, close it, and publish it in Integration Studio.

I hope this helps.

Let us know how it goes!


Paulo Tavares
Hey Paulo,

I am using Visual Studio 2010 Professional.  When I edit the solution and build it in visual studio it says "Build all succeeded".  Debug and Release both build successfully.  However, when I save it and close and then go back to Integration Studio, I still get the same error.


Hi Adam,

Would you have more than one version of Visual Studio installed?

I recommend going to the Integration Studio options, under Edit > Options, and then in the .Net tab, manually select the right compiler and properties. For instance, in my case - and these will most likely be different in yours - the values are:


C:\Program Files (x86)\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe



Compiler options:

/nologo /verbosity:minimal /target:Rebuild /property:Configuration=Release

I hope this helps. If not, I suggest you send an e-mail directly to our support department - - since that way they'll be able to get in touch with you directly and look into your specific scenario.

Let us know how it goes!


Paulo Tavares
Yes, I have Visual studio 2008 and 2010.  I edited the configurations under  Edit > Options, and then in the .Net tab to be

C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe

But I stil got the same error.

I ended up having to manually rewrite the \ContactsExtension.sln.cache file and added the following code


<PropertyGroup Condition=" ('$(Configuration)' == 'Release') and ('$(Platform)' == 'BWS') ">


<SolutionConfiguration xmlns="">

<ProjectConfiguration Project="{56CE2440-966F-4E62-BA90-6F2144846CCC}">Release|AnyCPU</ProjectConfiguration>




However, now I get the following error message:

Invalid Resource
Resource 'OutSystems.NssContactsExtension.dll' is empty and cannot be stored in the Binaries directory in the OutSystems Platform Server.

Errr... Well, that should not happen :)

I'd say that you should go back to the previous version of the extension, and then try pointing it to VS2008, and see if it works better. I believe that's the one I'm using.

If that doesn't work, do let our support team hear about it - they may have some insights on getting it to work when you have both VSs installed, or at least they will know what - if any - logs to ask from your computer, in order to troubleshoot it.


Paulo Tavares
OK I am contacting thesupport department.  I'll let you know what they say

Thanks for the help.
Problem solved:

Like you said Paulo, I went to the Edit > Options, and then in the .Net tab, again and I entereed the following:

/nologo /verbosity:minimal /target:Rebuild /property:Configuration=Release /p:Platform="Any CPU"

And it worked, no other errors, and it published just fine.


Solution Found.
Good to hear Adam.

Let us know how everything goes, and don't hesitate to let us know should you stumble on anything else.


Paulo Tavares
Same problem here.

Same solution:

/nologo /verbosity:minimal /target:Rebuild /property:Configuration=Release /p:Platform="Any CPU"

Worked fine!

Thank you!
Hi João,

Thanks for sharing. Glad you worked it out!

Regards, and keep up the good work.

Paulo Tavares
Sorry to necromance this thread, but this problem seems to still persist. After a hard disk crash I had to reinstall everything, and the default .NET Compiler Tool Options string is /nologo /verbosity:minimal /target:Rebuild /property:Configuration=Release, without the /p:Platform="AnyCPU". In fact, when you change .NET Compiler Tool option, it reverts to the faulty string again.
Hi Kilian,

Yes the problem persists. But it's not actually problem caused by the OutSystems Platform. The string should not need the AnyCPU. In fact you can have extensions that only compile in x64 bits, so we can't force the AnyCPU in the default setting.

The problem it's the way the .Net Compiler fallsback to the "Platform" enviroment variable if it's set. And a variable with that name is usually set on computers from some manufacturers (like HP).

Check this thread for more detailed information:

I'll see if I can add a workaround for it in the next major release of the platform :)

João Rosado
Hi João,

Thanks for the explanation. I have indeed an HP laptop, and checking the environment variables I see that "Platform" is set to "BNB", which was part of the error message.