[OutSystems Email Templates] "no stable version" error
Forge component by OutSystems R&D
Application Type
Reactive
Service Studio Version
11.12.0 (Build 48324)
Platform Version
11.13.0 (Build 31107)

I'm trying to install this component but I get the "No stable version for your environment" error and cannot install it via Service Studio.  As far as I can tell I have all the requirements:

  • Platform version 11.13.0 in all environments
  • Built-in emails for Reactive/Mobile enabled in Technical Preview for all environments
  • Latest version of Service Studio (checked in Windows and Cross-Platform versions)
  • Reactive application with email functionality in development

I was able to download the OML and install it in the dev environment, but the application does not appear in Service Studio or in dependency management.  I feel like I must be missing something obvious, but what could it be?  This is the first time I've encountered this scenario, any advice/guesses would be appreciated.

mvp_badge
MVP
Solution

That is a good question. It's possible to install it, but not from Service Studio I think.

Solution

Hello.
As far as I know, in order to appear from Service Studio, we need to have one version stable.
Since this component is still under development it won't appear, but you can install it manually at your own risk, which makes sense.

Cheers,
GM

I see, that does make sense.  Thanks for your help!

mvp_badge
MVP

Hi Douglas,

It seems there's only a single version available, and that is marked as "Under Development". That's why you get the "no stable version" message.

I'm still confused, is it not possible for anyone to install this?  Why is in the Forge if it can't be used?  

mvp_badge
MVP
Solution

That is a good question. It's possible to install it, but not from Service Studio I think.

mvp_badge
MVP

You're most welcome. An unofficial response I got from OutSystems: "Versions that are in development appear on the web so that the community can test and help improve the component."

Solution

Hello.
As far as I know, in order to appear from Service Studio, we need to have one version stable.
Since this component is still under development it won't appear, but you can install it manually at your own risk, which makes sense.

Cheers,
GM

I see, that does make sense.  Thanks for your help!

mvp_badge
MVP

Hi Douglas,

Just following up as I noticed that the component now has a stable version (since 6 October), so you should be able to install it the normal way from now on.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.