[OutSystems UI] Carousel shows more bullet points than there are items
outsystems-ui
Reactive icon
Forge component by Platform Maintenance
Application Type
Reactive


Hi community,

At the moment I am running into a problem that the carousel shows more bullets than there are items in the list (see image below). The same thing happens the other way around. When there are more than 4 items in the list, only 4 bullets are shown. When placing the image slider outside of all IF's shown below, the same thing is happening so I think I can rule out any of the IF's is causing the issue. Unfortunately I am not able to share a .oml so I'll try my best to show the situation by providing screenshots. Hopefully the issue can be identified.


  1. Data is fetched with a Data Action
  2.  IF is placed in screen to check if data is fetched
  3. Another IF is placed to check if there is media available
  4. Another IF is placed to check if only 1 media is found. If True, a Lightbox Image is shown, otherwise the carousel is being shown

When more information is needed, please let me know.

Best,

Bart

Solution

Ok I did replicate the issue, I just hope that this is the answer.

Can you please check your List Record Element. does it have any attribute?
You should have the property: "disable-virtualization" with the value "True".

This will prevent the creation of 2 elements inside your list.


Let me know if this unblocks you,

Regards,
João Ferreira

Hi @Bart Nooijens,

I did try to replicate this issue, but I didn't succeed.

I'll share my sample here.
Please check on your List Record the Source data, if everything is right. Let me know your OSUI version,
I've try it on 2.8.3 and 2.9.0. but the issue can be on another.

Best Regards,
João Ferreira

Sample_Reactive_Carousel.oml

Hi João,

Thanks for your reply!

We are currently using OutSystems UI 2.7.1.

I did check the List Record Source Data (see screenshot below).

Hope you can find something.

Best,

Bart

Solution

Ok I did replicate the issue, I just hope that this is the answer.

Can you please check your List Record Element. does it have any attribute?
You should have the property: "disable-virtualization" with the value "True".

This will prevent the creation of 2 elements inside your list.


Let me know if this unblocks you,

Regards,
João Ferreira

Hi,

Thanks for the reaction! Tomorrow I have a day off. I will check it on Friday. When I have tested your suggestion I will let you know.

Thanks,

Bart

Hi João,

Just tested this solution and seems to work properly!

Thanks,

Bart

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.