I can't login to outsystems service studio
Service Studio Version
11.54.5 (Build 62302)

I downloaded the environment for the first time and installed it,

I put in env the URL and my details below,

And when I click login it doesn't do anything,

what do I need to do?

Hello CC,

Unfortunately, there isn't much this community can do for you related to this. TRy to close and open again Service Studio. If the issue still occurs, my suggestion would be to open a support case and report the situation directly to OS. 

Issues with the service studio should be reported through the feedback button there. Like this (in yellow): 

If you still have the issue, you can always open a support ticket by clicking on the following link: 

Best regards, 



Dont worry !! Do this 

1.Forget Password 

2. Clear the cache and cookies of you browser.

3. Login  after 10 mints.

Could you please try to Reset the password again based on this documentation? Please follow the reminder below.


  1. After resetting, please wait at least 3-5 minutes before trying to log in, so that the new password can sync across the Lifetime, Service Center, and Service Studio.
  2. Please keep in mind that you can't try the wrong password before, to prevent the user from getting blocked (which might have been what happened). The block remains for approximately 60 minutes, even after a password reset.

If this wont work then raise the ticket to support

Kind regards

Sourabh Sharma

I had the exact same problem. I created an account, was able to login on the website but when I installed service studio, it wouldn't let me login, no error just didn't do anything. The next day i tried again, and it magically worked. It's probably when you create an account, the account will work, but your personal environment is still getting configured.. I suggest you just have to wait untill the next day or couple hours to have it working.

Also same exact problem. No message at all why the login failed. I would expect more from an App development company.  Tried waiting while. Very frustrating trial experience. I guess that's a no. Let's see if Mendix can do any better...

Hi @cc,

Can you please check this post

You might get the solution for your problem. Just follow the steps properly. 


Prince Kumar


I had exact same issue today and resolved it by my own. Please refer the below post where I had added by answer to give a try to resolve from your end as well. I am not sure if cause of the issue is same, but you can give a try for best. 




Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.