[Touch ID Plugin] TouchID is not defined
Question
Forge component by OutSystems R&D

I am getting this message in CheckTouchIdPlugin. Where is supposed this id to be defined?

Tried to install the app but iOS has error message: TouchID is not defined 

and in Android : TouchID is not supported error.  Only Fingerprint Id works. PLease help..

While in iOS , app generation is failed .. our MABS is 7.0.. Let know if the version 7.0 is  an issue. 

Staff

Hi Filipe,

If you're getting that message, probably you're using the plugin in a generated the native application. Touch ID only works natively (not on browser preview) and on a generated native application that is using the Touch ID Plugin (not on OS Now).

Is this the case?

Kind Regards,

João Grazina

Grazina wrote:

Hi Filipe,

If you're getting that message, probably you're using the plugin in a generated the native application. Touch ID only works natively (not on browser preview) and on a generated native application that is using the Touch ID Plugin (not on OS Now).

Is this the case?

Kind Regards,

João Grazina

Hi @Grazina,

I am testing an app that uses the Touch ID plugin natively on an Android device, and also get the error that the Touch Id is not defined. As for this thread, I updated the dependencies and reinstalled the native app (as well as trying the app with OutSystems Now just in case). I keep on getting the message that Touch Id is not defined, and after digging a bit in the Touch Id plugin, the origin is this:

, which means that there is an issue with the Fingerprint plugin of Android. I cannot find the solution anywhere, do you have any idea on how to solve this?

Thank you in advance.

Even TouchIdLoginSample application from forge is complaining about the same thing while debugging it by using Android device (Android q 10)


Does anyone have any idea why this is happening? 


Thanks.

Hi Filipe Lourenço,


Please confirm you have generated a new built after added a plugin. when you add new plugin, we need to generate a built. So that the plugin will work in application. If not, try generating a built and test again.


Regards,

Wasim Khan S


Tried to install the app but iOS has error message: TouchID is not defined 

and in Android : TouchID is not supported error.  Only Fingerprint Id works. PLease help..

While in iOS , app generation is failed .. our MABS is 7.0.. Let know if the version 7.0 is  an issue. 

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.