[Case Management framework] Case Management Framework Case Definition not valid
Question
case-management-framework
Service icon
Forge component by Platform Maintenance

I followed this path* to start with a casemanagement app and generated a GUID (version 4) for The CaseDefinitionID, but when saving a Case, it has an error saying that the DefinitionId (the GUID) is not valid.  

The error happens in the action

Case_Initialize


I used this to assign a value for the CaseDefinition

TextToIdentifier(Entities.CaseDefinitionConfiguration.CaseDefinition)

But I am not sure about The GUID either.....

Any one an Idea?




Hi Jeanette,

I have run into that problem before, and it's usually caused due to the the configuration timer not having run beforehand (the Case Definition needs to exist in the database before creating an instance of it). Make sure that you have followed the instructions as outlined here, and make sure that you have the Bootstrap configuration Timer set up in your CS module to run when published:

Also, a couple minutes after publishing again, verify that it has run successfully by going to Service Center > Monitoring > Timers, and you should see something like the screenshot below if everything happened successfully.


Let me know if that helps.

I checked the timer. I activated it manually. It has run. Also I see the record in the database. Tested creation of my entity. No success. After that I went checking if did not forgot something. Nothing.

But then, another time published. And after a while tested agina and then it worked.

Actually I did not change anything....

Thanx for your help!!! 

Hello, 

I check few time all the installation steps and it look like well configurated and deployed.

Unfortunatelly when I save a new case I receive the message error : case definition 'xxx...xx' is not valid. On debug mode I saw that the issue is on the create server action on the initialize step but I cannot debug more because The initialize server action is on the protected module 'CaseServices_API'. 

Just for your information,  the case configuration timer is scheduled on 'on publish' and I saw on  the timer monitoring the next run desactivated for the two timer specified by francisco and on the view data of the case definition, I see my case definition.

So what can I do to resolve the issue or at less understand what is not valid on my case definition?

Hi Alexis, 

My answer below is based on my interpretation that your timers DID run.....(am I right?)

Two possibilities:

1. Try to publish and test again. Check if it works. 

2. When not: try with another GUID. May be it was not unique. of may be it was not the right version. (I used version 4) Follow the steps. Publish. Wait. Try.


Hi, Jeanette.


Please check the following items before:

. The entity has the Identifier of type Case Identifier.

. The entity is exposing the events (Expose Process Events) More details at: https://success.outsystems.com/Documentation/11/Reference/OutSystems_Language/Data/Modeling_Data/Entity).

. There is a process that starts when the create event on the entity occurs.


I believe it could be one of those items.

I don't have an answer, but this issue is impacting me. And I don't necessarily want to wait around to see if it fixes itself.  

Was their ever a root cause discovered. 

I tried the recommended troubleshooting recommended above and I am still getting the same error as above when I call Case_Initialize. 

Thanks

Please note that you can also receive this error message if you have not created the workflow module that will contain the processes for the case definitions.

Please review step 6 in this document for more information.

https://success.outsystems.com/Documentation/Case_Management/Create_a_case_management_app#step6

Just in case the document is moved in the future, I have attached a screenshot of the relevant information.


Also, for anyone who was not having the problem previously and then the problem "randomly" appeared, this is more than likely due to you updating the Case Management framework. In version 1.3.1 there was a bug that would respond with case definitions that had no processes. This bug was fixed in the following version so that case definitions without processes are no longer returned and you will now receive this error in that scenario.

CMF-Step6.png

Hello,

I am facing same issue, did you found the solution for the same?

Thanks

Prajakta Roshankhede

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.